前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ 2071 Max Num

HDOJ 2071 Max Num

作者头像
谙忆
发布2021-01-20 16:20:02
5430
发布2021-01-20 16:20:02
举报
文章被收录于专栏:程序编程之旅

Problem Description There are some students in a class, Can you help teacher find the highest student .

Input There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.

Output For each case output the highest height, the height to two decimal plases;

Sample Input 2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00

Sample Output 180.00 182.00

同一个代码!这个运行时间正好是在超时的边界!~

代码语言:javascript
复制
import java.util.Scanner;
public class Main {

    static Scanner sc=new Scanner(System.in);
    public static void main(String[] args) {
        int n=sc.nextInt();
        while(n-->0){
                int m=sc.nextInt();
                double[] a=new double[m];
                double max=a[0]=sc.nextDouble();
                for(int i=1;i<a.length;i++){
                    a[i]=sc.nextDouble();
                    if(max<a[i]){
                        max=a[i];
                    }    
                }
                System.out.printf("%.2f",max);
                System.out.println();
            }

    }
}
本文参与?腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/01/28 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客?前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与?腾讯云自媒体同步曝光计划? ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档
http://www.vxiaotou.com