前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ 1003 Max Sum

HDOJ 1003 Max Sum

作者头像
谙忆
发布2021-01-20 16:24:14
2780
发布2021-01-20 16:24:14
举报
文章被收录于专栏:程序编程之旅

Problem Description Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input 2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output Case 1: 14 1 4

Case 2: 7 1 6

代码语言:javascript
复制
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        int time = 1;
        while(t-->0){
            int m = sc.nextInt();
            int p1,p2=1;
            int n = sc.nextInt();
            int now=n;
            int max=n;
            int x=1;
            p1=1;
            for(int i=1;i<m;i++){
                n=sc.nextInt();
                if(n>n+now){
                    x=i+1;
                    now=n;
                }else{
                    now = n+now;
                }
                if(now>max){
                    max=now;
                    p1=x;
                    p2=i+1;
                }


            }

            System.out.println("Case "+time+":");
            time++;
            System.out.println(max+" "+p1+" "+p2);
            if(t!=0){
                System.out.println();
            }

        }



    }

}
本文参与?腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/02/06 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客?前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与?腾讯云自媒体同步曝光计划? ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档
http://www.vxiaotou.com