前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【HDU 5007】Post Robot

【HDU 5007】Post Robot

作者头像
饶文津
发布2020-05-31 23:39:06
4760
发布2020-05-31 23:39:06
举报
文章被收录于专栏:饶文津的专栏饶文津的专栏

Description

DT is a big fan of digital products. He writes posts about technological products almost everyday in his blog.? But there is such few comments of his posts that he feels depressed all the day. As his best friend and an excellent programmer, DT asked you to help make his blog look more popular. He is so warm that you have no idea how to refuse. But you are unwilling to read all of his boring posts word by word. So you decided to write a script to comment below his posts automatically.? After observation, you found words “Apple” appear everywhere in his posts. After your counting, you concluded that “Apple”, “iPhone”, “iPod”, “iPad” are the most high-frequency words in his blog. Once one of these words were read by your smart script, it will make a comment “MAI MAI MAI!”, and go on reading the post.? In order to make it more funny, you, as a fan of Sony, also want to make some comments about Sony. So you want to add a new rule to the script: make a comment “SONY DAFA IS GOOD!” when “Sony” appears.?

Input

A blog article described above, which contains only printable characters(whose ASCII code is between 32 and 127), CR(ASCII code 13, ‘\r’ in C/C++), LF(ASCII code 10, ‘\n’ in C/C++), please process input until EOF. Note all characters are?case sensitive.? The size of the article does not exceed 8KB.

Output

Output should contains comments generated by your script, one per line.

Sample Input

Apple bananaiPad lemon ApplepiSony

233

Tim cook is doubi from Apple

iPhoneipad

iPhone30 is so biiiiiiig Microsoft

makes good App.

Sample Output

MAI MAI MAI!

MAI MAI MAI!

MAI MAI MAI!

SONY DAFA IS GOOD!

MAI MAI MAI!

MAI MAI MAI!

MAI MAI MAI!

题意:每行中有“Apple”, “iPhone”, “iPod”, “iPad” 出现则,输出MAI MAI MAI!,有Sony出现,输出SONY DAFA IS GOOD!

分析:读入用字符串读,然后用strstr函数,strstr(str1,str2)返回字符串str2在str1第一次出现的指针

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
char str[10240],ch[10][10]={"Apple", "iPhone", "iPod", "iPad" ,"Sony"};
int main(){
    while(~scanf("%s",str)){
        for(int i=0;i<4;i++)
            if(strstr(str,ch[i])-str>=0)
                printf("MAI MAI MAI!\n");
        if(strstr(str,ch[4])-str>=0)
            printf("SONY DAFA IS GOOD!\n");
    }
    return 0;
}
本文参与?腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-02-05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客?前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与?腾讯云自媒体分享计划? ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档
http://www.vxiaotou.com