前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【POJ 2243】Knight Moves

【POJ 2243】Knight Moves

作者头像
饶文津
发布2020-05-31 23:39:27
5210
发布2020-05-31 23:39:27
举报
文章被收录于专栏:饶文津的专栏饶文津的专栏

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.? Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.? Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

代码语言:javascript
复制
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

代码语言:javascript
复制
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

题意:骑士走法是日字型,或说L型,给出起点和终点,求起点到终点的最少步数

分析:广搜(bfs)

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
int vis[10][10];
int fx[8]= {1,1,-1,-1,2,2,-2,-2},
    fy[8]= {2,-2,2,-2,1,-1,1,-1};
struct node
{
    int x,y,step;
    bool operator == (const node b)
    {
        return x==b.x&&y==b.y;
    }
    bool ok()
    {
        return x<8&&x>=0&&y<8&&y>=0&&vis[x][y]==0;
    }
} fr,en,que[1000];
int bfs()
{
    if(fr==en)return 0;
    int coun=0,top=1;
    memset(que,0,sizeof(que));
    memset(vis,0,sizeof(vis));
    que[++coun]=fr;
    while(top<=coun)
    {
        node d=que[top];
        top++;
        node p;
        for(int i=0; i<8; i++)
        {
            p.x=d.x+fx[i];
            p.y=d.y+fy[i];
            p.step=d.step+1;
            if(p.ok())
            {
                if(p==en)return p.step;
                vis[d.x][d.y]=1;
                que[++coun]=p;
            }
        }
    }
}
int main()
{
    int fry,eny;
    char frx,enx;
    while(~scanf("%c%d %c%d",&frx,&fry,&enx,&eny))
    {
        fr.x=frx-'a';
        fr.y=fry-1;
        en.x=enx-'a';
        en.y=eny-1;
        printf("To get from %c%d to %c%d takes %d knight moves.\n",frx,fry,enx,eny,bfs());
        getchar();
    }
    return 0;
}
本文参与?腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-02-06 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客?前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与?腾讯云自媒体分享计划? ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档
http://www.vxiaotou.com